wiki.sine.space | sinespace

Difference between revisions of "Unity Installation"

From wiki.sine.space
Jump to: navigation, search
(Importing Existing Content)
 
(55 intermediate revisions by 7 users not shown)
Line 1: Line 1:
<div style="font-size: 20px; font-weight: bold; text-align: center;">The current recommended version is now 2017.2.3</div>
 
  
 
==Downloading Unity==
 
==Downloading Unity==
'''For Linux Users - please use 2017.2.1 from [https://forum.unity.com/threads/unity-on-linux-release-notes-and-known-issues.350256/page-2#post-3386889 this forum thread].'''
+
<strong>Quick Note for New Developer</strong>
  
 +
For production work use the Version of the Unity Editor 2017.4.39  for maximum stability and compatibility.
  
1. Go the Unity Download Archive [https://unity3d.com/get-unity/download/archive?_ga=1.231383836.2083880824.1472718379 Here]
+
For Windows - Download Unity 2017.4.39 -  [https://unity3d.com/get-unity/download?thank-you=update&download_nid=63529&os=Win  '''Here''']
  
2. Once on the Download Archive page, click on Unity 2017.x, then scroll down to 2017.2.3
+
Mac - Download Unity 2017.4.37 - [https://download.unity3d.com/download_unity/78b69503ebc4/UnityDownloadAssistant.dmg?_ga=2.230040542.338268820.1582920285-2074287522.1572011590 '''Here''']
  
3. If you are using a Windows system, click on the '''Downloads (Win)''' button, and on the drop-down menu, choose '''Unity Installer'''.
 
  
3a. If you are using a Mac system, click on the '''Downloads (Mac)''' button, and on the drop-down menu, choose '''Unity Installer'''.
+
===Advanced Users:===
  
 +
=====Compatible Unity Versions=====
  
 +
<strong> The following are included in our SDK/Editor Pack.</strong>
  
[[File:Unity201723.png]]
+
Unity 2018.4.20 has long term support from Unity and is the most recommended of the 2018 versions.  
  
 +
Unity 2018.1, 2018.2 and 2018.3, while robust they are Unity experimental builds and could stop working on our platform due to Unity updating features.
  
 +
2019.1 + while is in our SDK/Editor Pack 14 it is an experimental version and we do not have support for it on our platform at this time.
  
==Installing Unity==
+
Reports on any and all possible bugs in any version is appreciated on https://issues.sine.space/my_view_page.php
 +
 
 +
==Importing Existing Content==
 +
We <strong>strongly advise</strong> importing the Sinespace Editor Pack into a blank project.
 +
 
 +
Existing assets may incorporate incompatibilities in dependent assets, such as Unity's Post Stack V2 (which we bundle the Sinespace compatible version in our package, ditto Cinemachine.) which can cause conflicts.
 +
 
 +
To import existing content, we recommend creating a blank project, and import the assets into the new project, if you encounter incompatibilities please let us know!
 +
 
 +
==Note for Mac/Linux Users==
 +
You also need to have Mono installed on OSX for the editor pack to work.
 +
 
 +
For OSX we recommend a specific version you can get that here: [https://download.mono-project.com/archive/4.8.0/macos-10-universal/MonoFramework-MDK-4.8.0.382.macos10.xamarin.universal.pkg Download]
 +
 
 +
 
 +
'''Some assistance here [[for linux users]]'''
 +
 
 +
=Installing Unity for Mac=
  
 
When Unity has finished downloading, click Run to start the installation.
 
When Unity has finished downloading, click Run to start the installation.
Line 29: Line 49:
 
3. You will then see a screen called '''Choose Components'''. You will need to choose the following components from the list:
 
3. You will then see a screen called '''Choose Components'''. You will need to choose the following components from the list:
  
* Unity 2017.2.2
+
* Unity 2017.4.37
 
* Documentation
 
* Documentation
 
* Windows Build Support
 
* Windows Build Support
Line 35: Line 55:
 
All other components are optional (but can be installed if you want):
 
All other components are optional (but can be installed if you want):
  
[[File:Unityinstaller2.png]]
+
[[File:UnityInstaller3.png]]
  
 
4. After selecting these, click Next and choose your installation location.  
 
4. After selecting these, click Next and choose your installation location.  
  
 
This will start the download and installation process. Once finished, Unity will be installed.
 
This will start the download and installation process. Once finished, Unity will be installed.
 +
 +
=Next [https://wiki.sine.space/index.php?title=Download_Editor_Pack Download Editor Pack]=
  
  
 
{{Creation Navbox}}
 
{{Creation Navbox}}

Latest revision as of 18:43, 3 April 2020

Downloading Unity

Quick Note for New Developer

For production work use the Version of the Unity Editor 2017.4.39 for maximum stability and compatibility.

For Windows - Download Unity 2017.4.39 -  Here
Mac - Download Unity 2017.4.37 - Here


Advanced Users:

Compatible Unity Versions

The following are included in our SDK/Editor Pack.

Unity 2018.4.20 has long term support from Unity and is the most recommended of the 2018 versions.

Unity 2018.1, 2018.2 and 2018.3, while robust they are Unity experimental builds and could stop working on our platform due to Unity updating features.

2019.1 + while is in our SDK/Editor Pack 14 it is an experimental version and we do not have support for it on our platform at this time.

Reports on any and all possible bugs in any version is appreciated on https://issues.sine.space/my_view_page.php

Importing Existing Content

We strongly advise importing the Sinespace Editor Pack into a blank project.

Existing assets may incorporate incompatibilities in dependent assets, such as Unity's Post Stack V2 (which we bundle the Sinespace compatible version in our package, ditto Cinemachine.) which can cause conflicts.

To import existing content, we recommend creating a blank project, and import the assets into the new project, if you encounter incompatibilities please let us know!

Note for Mac/Linux Users

You also need to have Mono installed on OSX for the editor pack to work.

For OSX we recommend a specific version you can get that here: Download


Some assistance here for linux users

Installing Unity for Mac

When Unity has finished downloading, click Run to start the installation.

1. When the Unity Installer window opens, click Next

2. After that, accept the terms and conditions and click Next

3. You will then see a screen called Choose Components. You will need to choose the following components from the list:

  • Unity 2017.4.37
  • Documentation
  • Windows Build Support

All other components are optional (but can be installed if you want):

UnityInstaller3.png

4. After selecting these, click Next and choose your installation location.

This will start the download and installation process. Once finished, Unity will be installed.

Next Download Editor Pack